Important: please read through the entire lab because it contains useful information – it will save you time in the long run. AND remember you will be tested in concepts taken from both lecture and lab material. This lab may take more than the lab period – you are always expected to continue lab exercises beyond the class hours.

Goals. To:

1. familiarize yourself with spreadsheets
2. recognize problems that a spreadsheet can be useful for solving
3. use spreadsheets to effectively convey information, meaning, and context

Overview

1. Open Excel (either Mac or Windows)
2. Save it on your desktop as LastName_FirstName_Lab9 e.g. Hardy_Nazli_Lab9.
3. Follow this naming format for all future labs
4. Under no circumstances should there be any sharing of answers
5. Be sure to save your work on a flash drive or email the file to yourself before you log off – your work may/ will be lost upon you logging off.

Submission Guidelines

1. Once you have finished the lab, attach your spreadsheet to the email address listed at the top of this page – copy and paste the email address so that you are assured of reaching the correct email address.
2. Please do not email labs to my email account.
3. The heading of your email should be LastName_FirstName_Lab#

This lab will use the popular Microsoft Excel spreadsheet application to introduce spreadsheet concepts, but these concepts and procedures will be useful for using any spreadsheet application. At the end of this lab, you should be able to use a spreadsheet, and also be able to recognize problems that a spreadsheet can be useful for solving.

Discussion and Procedure

Part 1. What are spreadsheet applications good for?

Structuring data. Spreadsheets are most commonly used to store and perform calculations on numeric data. Examples of data like this include a checkbook record, business transaction records, data from scientific experiments (e.g., daily rainfall), and results of a survey. The first advantage of spreadsheets is that data can be stored in a structured way, making it easy to retrieve and present the data in different ways. Imagine, for example, keeping track of your expenses in a notebook, where you might list your expenses like this:
Storing the same data in a spreadsheet has several advantages over handwritten a record, many of which come from the structure that spreadsheets put on data. A spreadsheet is organized like a table, with cells arranged in columns and rows. This overall structure keeps the format of the entries and makes the data more readable.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>date</td>
<td>expense</td>
<td>amount</td>
</tr>
<tr>
<td>2</td>
<td>01/17/02</td>
<td>phone</td>
<td>$32.85</td>
</tr>
<tr>
<td>3</td>
<td>01/25/02</td>
<td>electricity</td>
<td>$18.47</td>
</tr>
<tr>
<td>4</td>
<td>02/01/02</td>
<td>rent</td>
<td>$640.00</td>
</tr>
<tr>
<td>5</td>
<td>02/12/02</td>
<td>cable</td>
<td>$26.00</td>
</tr>
<tr>
<td>6</td>
<td>02/18/02</td>
<td>phone</td>
<td>$52.02</td>
</tr>
<tr>
<td>7</td>
<td>02/26/02</td>
<td>electricity</td>
<td>$21.88</td>
</tr>
</tbody>
</table>

In addition to the overall structure provided by rows and columns of cells, you can specify the format (e.g., bold, italics…just like in a word processor) and data type (e.g., date, text, integer, real number, monetary amount) of a cell. In the example spreadsheet shown above, the cells in the first column are formatted as dates, so they are all displayed with the same month/day/year format. Similarly, the cells in the third column are formatted as currency amounts (in dollars), so they are all displayed with two decimal places and the dollar sign.
Structuring data this way has many advantages. You can use a spreadsheet to sort your data for different views of your data. You can also easily create visualizations of your data, in the form of bar, line, pie, and other graphs. We will see both of these features in this lab.

The main feature of a spreadsheet, however, is the ability to set up calculations on data that are automatically recomputed when you modify the data. In the example above, you might be interested in the total expenses. Later in this lab, you will see how to set up a cell whose value is automatically calculated from the values in other cells. Spreadsheets are often used to store business records and scientific data, because computations like averages, standard deviations, totals, etc. are commonly useful with such data.

Part 2. Creating and Editing a Spreadsheet

In this part, you will create a spreadsheet for keeping a daily record of how many hours you spend doing various things (e.g., studying, watching television, talking on the phone). This might be useful for reexamining your time management strategy. Just as with any programming, you should have a plan before starting work on your spreadsheet. Hands-on tasks will be indicated by the ► symbol.

First, decide what data your spreadsheet will store. In this case, it seems sensible to store each day’s data in a row. With one row per day, you should next decide what data you should have for each day, which determines what will be stored in the columns.

► Pick two activities you regularly engage in. With each row, you should store, in addition to the date, the number of hours spent that day on each of these activities, for a total of three columns.

► Start Excel. Microsoft Excel is often found on the Start menu under Start \ Programs \ Microsoft Office \ Excel if you are using Windows, or you will see it on your Desktop if you are using the Mac environment.

Most of the Excel window is occupied by your “worksheet,” the grid of cells where you will record your data. The Microsoft Office 2007 suite of applications has a common “look and feel”. Each application, including Excel, has a Ribbon bar at the top of the window, containing tabs and buttons. Below the Ribbon is an Excel-specific bar called the Formula bar, which we will use later. We will only use a few of the most essential features of Excel in this lab.

Note that each column can be identified by a letter, and each row by a number. This allows each cell in the grid to be identified by a cell reference, which is a letter-number combination such as A1 or B15. This will be useful later when defining formulas to perform automatic computations on your data.

► Enter column names in row 1 as shown below. Editing a cell is as easy as clicking the cell or using arrow keys to move to the cell you wish to edit, then typing the data value that you want in the cell. Enter column names in the first cells of Row 1 as shown below.

► Begin by entering the date 11/5/14 Cell A2, in the “Date” column.
For the other columns, for the purposes of this lab, just make up numbers for the number of hours for each of your activities.

Assuming you intend to record data on a daily basis, for approximately 10 days, you will have to fill in each day’s date in the “date” column. Typing these in by hand is not only tedious, but error-prone, so we will use a feature called “fill” to automatically enter a series of dates in this column.

Select about 10 cells in the “date” column, starting from cell A2. To select a group of cells, use the mouse and drag over the cells you want to select. You can select any rectangular region of cells this way.

Before you go on to the next step, make sure that you have the cell with the date you just entered and several cells directly below it selected.

Fill the selected region using the following technique. From the Ribbon bar, select Home \ Editing \ Fill \ Series....

A dialog box will appear with options for the fill series. Make sure Series in Columns, Type Date, Date unit Day, and Step value 1 are selected. These options specify that the series you want runs down a column, as opposed to across a row, (2) that the data type in these cells is Date, and that (3) the dates in this series should go up by one day per cell.

Click the OK button.
The filled series should look as follows:

![Image of a spreadsheet with dates and columns for Work, Entertainment, and Studying]

- Fill in the rest of the columns for each day using numbers you find appropriate.

### Part 3. Functions for Automatic Calculations on Your Data

For data like this, it might be useful to calculate values like the total hours and the average hours spent daily on each activity. These values are different from the data in that they are not values that you enter directly but are calculated from the data you enter. Using a function, you can set up a spreadsheet cell to display the result of such a calculation. A spreadsheet function is just like a formula or mathematical function in that it is used to compute a value based on the values of one or more variables. In the case of a spreadsheet function, you can set up a cell to perform some computation (like finding the sum or average) on the values in other cells in your spreadsheet. The advantage of a spreadsheet function is that this cell's value is automatically updated whenever the data in the other cells is changed.

- Set up text labels for the total and daily average number of hours spent on each activity.
- Select the cell for the total time for your first activity (B13 in the example).
- Click the **AutoSum** button on the Ribbon as shown below.
Press the Enter key to enter the formula in the cell.

Instead of entering a value in this cell, you have now entered a formula called `SUM`, which adds the values in a range of cells. In this case, the `AutoSum` button has guessed that you want the sum of the values in the cells directly above the currently selected cell. You should now see the total number of hours for this activity as the value for this cell. Click the cell again to see its contents in the formula bar, and note the syntax of the formula in the cell's contents, which should look like, `="SUM(B2:B10)"`.

Let's break down this cell's contents to see how it computes the total value shown. The equals sign in `="SUM(B2:B10)"` means that this cell contains a function, rather than a fixed value. The function (in this case, `SUM`) is indicated after the equals sign, and the `B2:B10` part in the function’s parentheses is the function’s parameter. (Parameter is actually a general computing term, and we’ll see it again when we work with programming.)

Test the automatic recalculation of a formula cell. Change one of the timings for the activity for which you just created a total cell. The total should automatically update as soon as you enter the new value.

Set up a total time cell for your other activities by copying and pasting the formula. Although you could follow the same instructions as above to set up your second activity’s total time cell, there is an easier way. Select the first activity’s total time cell and copy it by clicking the Ribbon bar `Copy` button (Edit > Copy or pressing Ctrl-C). Select the cell where you want the second activity’s total time and paste by clicking the Ribbon bar `Paste` button ( ), selecting Edit > Paste or pressing Ctrl-V. Note that the contents of the new total time cell has a formula that is similar but not identical to the original. Excel guesses that you want the new total time cell’s formula to work on the column of cells above it, rather than be an exact copy of the first total time cell.

Set up an average daily time cell for your first activity.
Select the cell where you want the average daily time for your first activity (Work) to be displayed (B12 in the example). This time, instead of clicking the AutoSum button, click the **Formula Tab** and then this button (fx).

Select the **AVERAGE** function.

Click the **OK button**.

Adjust the range of cells the average should be calculated over - in my case it is (B2:B13).

Click the **OK button**.

Copy the contents of the cell for the average of activity 1 to the cell for the average of activity 2, to copy the average formula to the column for the second activity.

“Decrease decimal” of the averages to one decimal point:
Part 4. Charts for Visualizing Data

Visualizing data in charts can often make it easier to interpret. In this part, you will use Excel to create a chart showing daily time spent on your activities, like the one shown below.

► Select the cells you have filled in – see my example below.

► Click the Insert tab (to the right of the Home tab)

► Click the Line Chart button, and 2D Line chart type as shown below.

The chart will appear, as shown below.
Although we have only worked with one worksheet, a single Excel spreadsheet file can contain multiple sheets, including sheets devoted to charts.

**Sorting Data**
The way you have entered your timing data, the rows are ordered by date. You might, however, be interested in seeing which days you spent the most time on a certain activity. More generally, you might be interested in sorting your rows by a column other than date.

Select only the hours for activity 1 (column C)

Click the Sort & Filter button and select Sort Largest to Smallest as shown below.

Note that the data in the table is sorted such that column B is sorted from largest to smallest, but your chart does not change. This is because your sorting did not change data in each row; it just reordered the rows. The chart itself is not affected by the row order.
Create a Column Chart

► Using the knowledge of what you have learned so far, create a 3D column chart showing how your total time splits across the activities you chose.

Further Activities (you do not need to hand this part but it is good practice)

Experiment with other types of charts – e.g. create a pie chart chart showing how your total time splits across the activities you chose.

Experiment by clicking on the data of the x and y axis, as well as the series.

Do a web search for “spreadsheet history” to find more information about spreadsheets, including the history of the application, which was first introduced in 1978 by Robert Frankston and Dan Bricklin as the application Visicalc.